Back to overview
Degraded

Potential network issues

Nov 18, 2025 at 1:00pm UTC
Affected services
Website
Job board
API

Resolved
Nov 18, 2025 at 3:06pm UTC

The network incident should be resolved.

Created
Nov 18, 2025 at 1:00pm UTC

Potential network issues in some regions due to a Cloudflare outage.